【pat考试】1003 Emergency (25)

内容纲要

1003. Emergency (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output

2 4

先是没看清是求得最短路数目 直接BFS搞 wa半天发现看错题 继续BFS 还是跪 发现要一层一层的搜才能知道所有的最短路 改的有点恶心 还是换dfs搜了 一次AC

#define DeBUG
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <vector>
#include <stack>
#include <queue>
#include <string>
#include <set>
#include <sstream>
#include <map>
#include <list>
#include <bitset>
using namespace std ;
#define zero {0}
#define INF 0x3f3f3f3f
#define EPS 1e-6
#define TRUE true
#define FALSE false
typedef long long LL;
const double PI = acos(-1.0);
//#pragma comment(linker, "/STACK:102400000,102400000")
inline int sgn(double x) {return fabs(x) < EPS ? 0 : (x < 0 ? -1 : 1);}
#define N 100005
int n, m, s, e;
int v[505];
int mp[505][505];
int price[505];
int getp[505];
int num[505];
int vis[505];
void dfs(int now)
{
    int tmp;
    if (now == e)
        return;
    for (int i = 0; i < n; i++)
    {
        if (mp[now][i] != INF && !vis[i])
        {
            tmp = mp[now][i] + price[now];
            if (tmp < price[i])
            {
                price[i] = tmp;
                getp[i] = getp[now] + v[i];
                num[i] = num[now];
                vis[i] = 1;
                dfs(i);
                vis[i] = 0;
            }
            else if (tmp == price[i])
            {
                if (getp[now] + v[i] > getp[i])
                    getp[i] = getp[now] + v[i];
                num[i]++;
                vis[i] = 1;
                dfs(i);
                vis[i] = 0;
            }
        }
    }
    return;
}
int main()
{
#ifdef DeBUGs
    freopen("/Users/sky/Documents/sublime project/in.txt", "r", stdin);
#endif
    while (scanf("%d%d%d%d", &n, &m, &s, &e) + 1)
    {
        memset(mp, INF, sizeof(mp));
        memset(price, INF, sizeof(price));
        memset(getp, 0, sizeof(getp));
        memset(num, 0, sizeof(num));
        for (int i = 0; i < n; i++)
        {
            scanf("%d", &v[i]);
        }
        int a, b, c;
        for (int i = 0; i < m; i++)
        {
            scanf("%d%d%d", &a, &b, &c);
            if (c < mp[a][b])
                mp[a][b] = mp[b][a] = c;
        }
        price[s] = 0;
        num[s] = 1;
        getp[s] = v[s];
        vis[s] = 1;
        dfs(s);
        // for (int i = 0; i < 5; i++)
        // {
        //     printf("%d ", price[i]);
        // }
        // printf("\n");
        // for (int i = 0; i < 5; i++)
        // {
        //     printf("%d ", getp[i]);
        // }
        // printf("\n");
        // for (int i = 0; i < 5; i++)
        // {
        //     printf("%d ", num[i]);
        // }
        // printf("\n");
        printf("%d %d\n", num[e], getp[e]);
    }
    return 0;
}

附上几个从人家那里拿来的测试用例 帮我发现了错误

6 9 0 5
1 2 1 5 3 4
0 1 1
0 2 2
0 3 1
1 2 1
2 3 1
2 4 1
2 5 1
3 4 1
4 5 1
6 9 0 2
1 2 1 5 3 4
0 1 1
0 2 2
0 3 1
1 2 1
2 3 1
2 4 1
2 5 1
3 4 1
4 5 1
6 9 0 4
1 2 1 5 3 4
0 1 1
0 2 2
0 3 1
1 2 1
2 3 1
2 4 1
2 5 1
3 4 1
4 5 1

答案

4 13

3 7

1 9

发表回复